マニュアル

  1. サーバープログラムについて
  2. PHPのバージョンについて

PHPのバージョンについて

お客様がご利用のサーバーによって、ご利用いただけるPHPのバージョンが異なります。

※サーバー番号の確認方法は、よくある質問「利用しているサーバーの番号はどこで確認できますか?」をご参照ください。

  • 〜sv1999の場合
  • sv2001〜の場合

ご利用いただけるPHPのバージョン

バージョン説明
PHP 7.0.7

現在公式にサポートされているバージョンです。
PHP7 は、PHP5 や PHP4 と比較してパフォーマンスが大幅に強化されています。

※「PHP高速化設定(FastCGI)」と「キャッシュモジュール(OPcache)」が
標準で有効となります。
「FastCGI」と「OPcache」については、 マニュアルページ「FastCGIについて」と 「APC/OPcacheについて」をご参照ください。

※PHP4、PHP5系統からのバージョン変更の際には、プログラムが正常に動作するか必ずご確認ください。

PHP 5.6.22

現在公式にサポートされているバージョンです。

※「PHP高速化設定(FastCGI)」と「キャッシュモジュール(OPcache)」が
標準で有効となります。
「FastCGI」と「OPcache」については、 マニュアルページ「FastCGIについて」と 「APC/OPcacheについて」をご参照ください。

PHP 5.5.30

旧バージョンです。
今後バージョンアップの予定はないため新規での利用は推奨しません。
PHP 5.6.x への移行を推奨します。

PHP 5.4.45
PHP 5.2.17
PHP 4.3.9
PHP 5.3.3

旧バージョンです。
OSベンダーによるパッチにて、影響の大きな脆弱性を中心にセキュリティ修正が
行われます。
PHP5.6 への移行を推奨します。

PHP 5.1.6

ご利用いただけるPHPのバージョン

バージョン説明
PHP 7.0.9

現在公式にサポートされているバージョンです。
PHP7 は、従来のPHPと比較してパフォーマンスが大幅に強化されています。

※PHP5系統からのバージョン変更の際には、プログラムが正常に動作するか必ずご確認ください。

PHP 5.6.24

現在公式にサポートされているバージョンです。

PHP 5.5.38

旧バージョンです。
今後バージョンアップの予定はないため新規での利用は推奨しません。
PHP5.6 への移行を推奨します。

PHP 5.4.16

旧バージョンです。
OSベンダーによるパッチにて、影響の大きな脆弱性を中心にセキュリティ修正が
行われます。
PHP5.6 への移行を推奨します。

PHP 5.3.3
PHP 5.1.6
  • ※いずれのバージョンも「PHP高速化設定(FastCGI)」と「キャッシュモジュール(APC/OPcache)」が標準で有効となります。
    各バージョンにおける設定内容については、マニュアルページ「PHP高速化設定について」をご参照ください。

PHPのバージョン切り替え

1.「PHP Ver.切替」をクリック

サーバーパネルへログインし、「PHP Ver.切替」をクリックしてください。

PHPver.切替画面へ

2.変更後のバージョンを設定

現在のバージョンを確認し、「変更後のバージョン」より変更希望のバージョンを選択ください。

サーバーパネルでPHPver.切り替えをクリック

選択後、「バージョンを切り替える」をクリックしてください。